Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By HappyChris

Thread: OMG! OTG says '< waiting for device >'

  1. #1
    Member HappyChris's Avatar
    Join Date
    Jul 2012
    Posts
    51
    Member #
    2249
    Liked
    6 times

    OMG! OTG says '< waiting for device >'

    Another stumbling block on my way to rooted N10 heaven is that my OTG cables (two) don't seem to be visible when serious stuff needs to be done. If connected to my Windows XP laptop, ADB fails to recognise it and nothing appears in Explorer. If connected to my iMac via AFT, its files can be seen and transferred back and forth. USB Debugging is, of course, set.

    In spite of the above, when I try to run 'su ./fastboot-mac oem unlock' from the Terminal the screen says '< waiting for device >', the same as it would say if nothing was connected. The channels are open for normal stuff but not for this.

    Any idea what's going on, please?

    Update: chanced upon another thread which advised running the command 'sudo fastboot device' after connecting the tablet to the PC to establish communication. Did this and saw the tablet's ID in response to the command. After the 'oem unlock' bit all went as hoped... until the reboot and - after seeing the unlock logo appear, the boot animation 'X' just pulsed away :-(. BTW, on the bootloader screen, the 'reboot mode flag' says 'none' and 'lock state; says 'unlocked', which gives some hope.

    Now to find out how to get past the 'X'... ;-)
    Last edited by HappyChris; 08-07-2013 at 10:51 AM. Reason: Update

  2. #2
    Senior Member BHuber09's Avatar
    Join Date
    Jun 2012
    Location
    Atlantis
    Posts
    147
    Twitter
    BHuber09
    Tablet
    Nexus 10
    Member #
    151
    Liked
    32 times
    Are you on ubuntu?

  3. #3
    Member HappyChris's Avatar
    Join Date
    Jul 2012
    Posts
    51
    Member #
    2249
    Liked
    6 times
    No I run OS X on my iMac and usual Android on my Androids.

  4. #4
    Senior Member jeems's Avatar
    Join Date
    Jul 2012
    Location
    Elvis needs boats
    Posts
    1,597
    Member #
    1695
    Liked
    192 times
    HAve you tried Wug's nexus rootkit? http://www.nexus7nexus10.com/forum/n...-v1-6-3-a.html

    It can unlock, lock, restore from bricked, etc. It's pretty slick.
    He who can no longer pause to wonder and stand rapt in awe, is as good as dead; his eyes are closed.
    -Albert Einstein

  5. #5
    Member HappyChris's Avatar
    Join Date
    Jul 2012
    Posts
    51
    Member #
    2249
    Liked
    6 times
    I did with my XP laptop but it failed to connect, hence going to my iMac. I'll try it again now that the fastboot is working...

  6. #6
    Member HappyChris's Avatar
    Join Date
    Jul 2012
    Posts
    51
    Member #
    2249
    Liked
    6 times
    Many thanks for your responses in my hours of dread! I Got it sorted and am back with 4.3 and it's unlocked still. Hooray!

    My sticking points were the key presses and how to proceed to install fastboot and what to do when faced with the 'dead' android with the danger sign over its open belly. When Wug failed to work for me I was glad to have a Mac to fall back to. I knew it would (eventually) work, having had my faith strengthened by seeing "http ://www.youtube.com/watch?v=b7W3bFNdJ8I" and ZedoMax's other videos.

    To other Mac non-iPaddites who hit these problems: give his videos a close look. Why lose heart and go back to suffocate in the 'walled garden' when you don't need to?
    jeems likes this.

  7. #7
    Senior Member jeems's Avatar
    Join Date
    Jul 2012
    Location
    Elvis needs boats
    Posts
    1,597
    Member #
    1695
    Liked
    192 times
    Glad you got it working. Wugs is nice when it works. It works awesome for my gnex but I've had trouble with my n7.
    He who can no longer pause to wonder and stand rapt in awe, is as good as dead; his eyes are closed.
    -Albert Einstein

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Waiting with bated breath...UPS come ON already!
    By Rosalie in forum New Member Introduction & Site Assistance
    Replies: 12
    Last Post: 09-27-2012, 10:41 PM
  2. Device Administrators
    By sgione in forum Nexus 7 Help
    Replies: 2
    Last Post: 09-15-2012, 12:31 PM
  3. Nexus 7 owner in a few hours .. waiting for UPS :-)
    By mic141414 in forum New Member Introduction & Site Assistance
    Replies: 14
    Last Post: 08-25-2012, 11:28 PM
  4. Replies: 11
    Last Post: 07-23-2012, 06:43 PM
  5. Replies: 3
    Last Post: 07-13-2012, 10:55 AM

Search tags for this page

fastboot oem unlock waiting for device
,
how can i get otg to work on mac os10.4 and nexus 7??
,

nexus 7 going back and forth from the logo and the x

,

nexus 7 waiting for device

,

nexus toolkit waiting for device

,
toolkit says nexus4 waiting for device
,
waiting for device stack on nexus toolkit
,
waiting for device toolkit nexus 7
Click on a term to search for related topics.